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Layer Basics

Lesson overview

In this lesson, you'll learn how to do the following:

+ Organize artwork on layers.

« Create, view, hide, and select layers.

« Rearrange layers to change the stacking order of artwork in the image.
« Apply blending modes to layers.

« Link layers to work on them simultaneously.

+ Apply a gradient to a layer.

+ Add text and layer effects to a layer.

« Save a copy of the file with the layers flattened.

This lesson will take about an hour to complete. If needed, remove the
previous lesson folder from your hard drive, and copy the Lesson05 folder
onto it. As you work on this lesson, you'll preserve the start files. If you
need to restore the start files, copy them from the Adobe Photoshop CS3
Classroom in a Book CD.

About layers

Every Photoshop file contains one or more layers. New files are generally
created with a background layer, which contains a color or an image that
shows through the transparent areas of subsequent layers. All new layers
in an image are transparent until you add text or artwork (pixel values).

Working with layers is analogous to placing portions of a drawing on
sheets of acetate: Individual sheets of acetate may be edited, repositioned,
and deleted without affecting the other sheets. When the sheets are

stacked, the entire composition is visible.
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Getting started

You'll start the lesson by viewing an image of the final composition.

1 Start Photoshop and then immediately hold down Ctrl+Alt+Shift (Windows) or
Command+Option+Shift (Mac OS) to restore the default preferences. (See “Restoring
default preferences” on page 6.)

2 When prompted, click Yes to confirm that you want to reset preferences, and Close to
close the Welcome Screen.

3 Click the Go To Bridge button (&) in the tool options bar to open Adobe Bridge.

4 In the Folders panel, click Lessons; then double-click to open the Lesson05 folder,
and select the 05End.psd file to preview it.

This layered composite represents the cover of a scrapbook. You will create it now, and
in doing so, learn how to create, edit, and manage layers.

5 Select the 05Start.psd file and double-click it to open it in Photoshop.

6 Choose File > Save As, rename the file 05Working.psd, and click Save. By saving
another version of the start file, you don’t have to worry about overwriting the original.
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Using the Layers palette

The Layers palette displays all layers with the layer names and thumbnails of the
images on each layer. You can use the Layers palette to hide, view, reposition, delete,
rename, and merge layers. The palette thumbnails are automatically updated as you
edit the layers.

1 If the Layers palette is not visible in the work area, choose Window > Layers.

05Working.psd @ 100% (Photo, RGB/8#)

=

| Layers x | Channels | Paths | .=

100% |7

The Layers palette lists five layers for the 05Working file (from top to bottom): a type
layer called 2, Shell, Letter, Paper texture, and Background.

2 Click to select the Background layer to make it active (if it is not already selected).
Notice the layer thumbnail and the icons on the Background layer level:

« The lock icon (&) indicates that the layer is protected.

+ The eye icon (®) indicates that the layer is visible in the image window. If you click
the eye, the image window no longer displays that layer.
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About the Background layer

When you create a new image with a white or colored background, the bottom layer in the Layers
palette is named Background. An image can have only one background. You cannot change the
stacking order of a background, its blending mode, or its opacity. You can, however, convert a
background to a regular layer.

When you create a new image with transparent content, the image does not have a Background layer.
The bottom layer is not constrained like the Background layer; you can move it anywhere in the Layers
palette, and change its opacity and blending mode.

To convert a background into a layer:

1 Double-click the name Background in the Layers palette, or choose Layer > New > Layer From
Background.

2 Set layer options as desired, including renaming the layer.
3 Click OK.

To convert a layer into a background:

1 Select a layer in the Layers palette.

2 Choose Layer > New > Background From Layer.

Note: You must use this command to create a background from a regular layer; you cannot create a
background simply by renaming a regular layer Background.

Renaming and copying a layer

Creating a new layer can be as simple as dragging from one file into the image window
of another file. Whether you drag from the image window of the original file or from
its Layers palette, only the active layer is reproduced in the destination file. Before you
begin, make sure that both the 05Start.psd and Photo.psd files are open, and that the
Photo.psd file is active.

First, you will give Layer 1 a more descriptive name.
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1 In the Layers palette, double-click the name Layer 1, type Photo, and then press
Enter or Return. Keep the layer selected.

e e e Y S > o
| Layers x | Channels fPaths | .= | Leyers x | Chennels | Paths | .=
Mormal | opacity: | 1003 > | [Mormal | opacity: | 1009 » |

Lock: [ #+ @ Fill:| 10096 * locki O 2+ @ Fill| 100% *

Photo

2 If necessary, drag the Photo.psd and 05Working.psd image windows so that you can
see at least part of both images on-screen. Then, select the Photo.psd image so that it is
the active file.

3 In the toolbox, select the Move tool (*+) and position it over the Photo.psd
image window.

4 Drag the photo image and drop it into your 05Working.psd image window.

& photo.psd @... J;HE"XT
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The Photo layer now appears in the 05Working.psd file image window and its Layers
palette, between the Paper texture and Background layers.

| Morrmal

locki [ - @ Fill:éwiruﬁogé:”j
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D Shell

D Letter
IZI Paper texture

Q

W Backoround

= A& 0 ® 2 a3

5 Close the Photo.psd file, and do not save your changes to that file.

Q If you hold down Shift as you drag an image from one file into another, the dragged
image automatically centers itself in the target image window.

Viewing individual layers

The Layers palette shows that the 05Working.psd file now contains six layers, some of
which are visible and some of which are hidden. The eye icon (®) to the far left of a layer
name in the palette indicates that that layer is visible.

1 Click the eye icon (®) next to the Photo layer to hide the photo.

You can hide or show a layer by clicking this icon or clicking in its column—also called
the Show/Hide Visibility column

2 Click again in the Show/Hide Visibility column to reveal the photo.
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2 To make the opaque areas on this layer more obvious, hide all layers except the Photo
layer by holding down Alt (Windows) or Option (Mac OS) and clicking the eye icon (®)
next to the Photo laver.

The blue background and other objects in the start image disappear, and the photo
appears against a checkerboard backdrop. The checkerboard indicates transparent areas
of the active layer.

3 Select the Magic Eraser tool (), hidden under the Eraser tool ().

Now you will set the tolerance for the Magic Eraser tool. If the tolerance is too low,
the Magic Eraser tool leaves some white remaining around the photo. If the tolerance
setting is too high, the Magic Eraser tool removes some of the photo image.

4 In the tool options bar, set the Tolerance value either by scrubbing the Tolerance label
or by typing 22 in the Tolerance text box.
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5 Click the white area around the photo in the image window.

The white area is replaced by the checkerboard, indicating that this area is now

transparent.

6 Turn the background back on by clicking in the Show/Hide Visibility column next to
its name. The blue scrapbook background now shows through where the white area on
the Photo layer has become transparent.
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Rearranging layers

The order in which the layers of an image are organized is called the stacking order. The
stacking order of layers determines how the image is viewed—you can change the order
to make certain parts of the image appear in front of or behind other layers.

Now, you'll rearrange layers so that the photo image is in front of another image that is
currently hidden in the file,

1 Make the Shell, Letter, and Paper texture layers visible by clicking the Show/Hide
Visibility column next to their layer names.
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Now you can see that the photo image is partially blocked by these other images on
other layers.

Note: The Photo layer is also below the 2 type layer, which is at the top of the stack, but
you'll leave that layer hidden for the moment. You'll get to it later in this lesson.
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Changing the opacity and mode of a layer

The opaque crinkled piece of paper blocks the blue background in the layer below it.
You can reduce the opacity of any layer to let other layers show through it. You can also
apply different blending modes to a layer, which affect how the color pixels in the opaque
image blend with pixels in the layers underneath. (Currently, the blending mode is
Normal.) Let’s edit the Paper texture layer to let the background show through.

1 Select the Paper texture layer, and then click the arrow next to the Opacity box in the
Layers palette and drag the slider to 50%. Or, type the value into the Opacity box, or
scrub the Opacity label.
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The Paper texture becomes partially transparent, and you can see the background
underneath. Notice that the change in opacity affects only the image area of the Paper
texture layer. The letter, photo, and shell images remain opaque.
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2 To the left of the Opacity option in the Layers palette, click the Blending Mode
pop-up menu to open it, and choose Luminosity.

3 Increase the Opacity to 75%.
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4 Choose File > Save to save your work.

Q For more about blending modes, including definitions and visual examples, see
Photoshop Help.

Linking layers

Sometimes an efficient way to work with layers is to link two or more related layers.

By linking layers together, you can move and transform them simultaneously, thereby
maintaining their relative alignment.

You'll link the Photo and Letter layers, and then transform and move them as a unit.

1 Select the Photo layer in the Layers palette, and then press Shift and click to select the
Letter layer.
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2 Click the icon (~=) in the upper right of the Layers palette to display the palette
menu; choose Link Layers. Or, click the Link Layers button at the bottom of the palette.

JLayer;x Channels | Paths |

: an

A link icon (=) appears next to both of the layer names in the Layers palette, indicating
that they are linked.

Now, you'll resize the linked layers.

3 With the linked layers still selected in the Layers palette, choose Edit > Free
Transform. A transform bounding box appears around the images in the linked layers.

4 Hold down Shift and drag a corner handle inward, scaling the photo and the letter
down by about 20%.
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5 'Then, with the pointer inside the bounding box, drag the photo and the letter images
to reposition them down and to the left in the image window so that the montage
resembles the following image.
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6 Press Enter or Return to apply the transformation changes.

7 Choose File > Save.

Adding a gradient layer

Next, you'll create a new layer with no artwork on it. (Adding empty layers to a file is
comparable to adding blank sheets of acetate to a stack of images.) You'll use this layer
to add a semitransparent gradient effect that influences the layers stacked below it.

1 In the Layers palette, select the Paper texture layer to make it active, and then click
the New Layer button (al) at the bottom of the Layers palette.

A new layer, named Layer 1, appears between the Paper texture and the Letter layer.
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Note: You can also create a new layer by choosing New Layer from the Layers palette menu

or Layer > New > Layer in the Photoshop menu bar.
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2 Double-click the name Layer 1, type Gradient, and press Enter or Return to rename
the layer.
3 In the toolbox, select the Gradient tool ().

4 In the tool options bar, make sure that the Linear Gradient button (CH) is selected,
and then click the small downward arrow to expand the gradient picker.

5 Select the Foreground to Transparent swatch, and then click anywhere outside the

gradient picker to close it.

Q You can list the gradient options by name rather than by sample. Just click the right-
pointing palette menu button (®) on the gradient picker and choose either Small List or
Large List. Or, hover the pointer over a thumbnail until a tooltip appears, showing the

gradient narme.
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6 Click the Swatches tab to bring that palette to the front of its group, and select a

shade of green that appeals to you.

A F

7 With the Gradient layer still active in the Layers palette, drag the Gradient tool from

the lower right corner of the image to the upper left corner.
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The gradient extends across the layer, starting with green on the lower right and
gradually blending to transparent on the upper left. The gradient partially obscures the
paper texture and background below it, so you'll change its blending mode and reduce

its opacity to partially reveal those images.
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8 With the Gradient layer still active, in the Layers palette choose Multiply from the
Blending Mode pop-up menu and change the Opacity to 75%; click OK. Now, the Paper
texture and Background layers show through the gradient.
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Adding text

Now, you're ready to create some type using the Horizontal Type tool, which places the
text on its own type layer. You'll then edit the text and apply a special effect to that layer.

1 Deselect all layers in the Layers palette by clicking outside the layer names (drag to
enlarge the palette to create a blank area, if necessary).

2 Set the foreground color to black by clicking the small Default Foreground and
Background Colors button (®) near the swatches in the toolbox.

3 In the toolbox, select the Horizontal Type tool (T). Then, in the tool options bar, do
the following:

« Select a serif font from the Font pop-up menu (we used Adobe Garamond).

« Select a font style (we used Italic).
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« Enter a large point size in the Size text box (we used 76 points), and press Enter
or Return.

« Select Crisp from the Anti-aliasing pop-up menu (2a).

+ Select the Right align text (=) option.

]
| |

T - | 1T | Adobe Garamon.., v‘ Ttalic -VJ «I’-I"—?s pt ~ | ag|crisp v

= M 1 B

4 Click in the upper right corner of the letter area in the image window and type
Scrapbook. Then, click the Commit Any Current Edits button (v).

Note: If you make a mistake when you click to set the type, simply click away from the type
and repeat Step 4.

The Layers palette now includes a layer named Scrapbook with a “T” thumbnail icon,
indicating that it is a type layer. This layer is at the top of the layer stack.
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The text appears in the area of the image where you clicked, which probably isn't exactly
where you want it to be positioned.
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5 Select the Move tool (*+), and drag the “Scrapbook” text so that the baseline aligns
with the top right edge of the letter.

Afar Aptiin -

Y acxe Vot oA ,o,w‘?é:( ey SRR

v of o frrest o
: o dhall

Applying a layer style

You can enhance a layer by adding a shadow, glow, bevel, emboss, or other special effects
from a collection of automated and editable layer styles. These styles are easy to apply
and link directly to the layer you specify.

Like layers, layer styles can be hidden by clicking eye icons (®) in the Layers palette.
Nondestructive, styles can be removed at any time. You can apply a copy of a layer style
to a different layer by dragging the effect onto the destination layer.

Now, you'll make the text stand out by adding a bevel and drop shadow around the type,
and coloring the text yellow.

1 With the Scrapbook type layer active, choose Layer > Layer Style > Bevel and
Emboss. (The Layer Style dialog box may take a moment or two to open.)

Q You can also open the Layer Style dialog box by clicking the Add Layer Style
button (fx) at the bottom of the Layers palette and then choosing a layer style, such as
Bevel and Emboss, from the pop-up menu.
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2 In the Layer Style dialog box, make sure that the Preview option is selected, and
then move the dialog box aside as needed so that you can see the Scrapbook text in the
image window.

3 In the Structure area, make sure Style is Inner Bevel and Technique is Smooth. Then,
set Depth at 50%, Size to 5 pixels, and Soften to 0 pixels. Choose Up for your Direction.
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4 In the left pane of the Layer Style dialog box, click the name Drop Shadow at the top
of the Styles list. Photoshop automatically checks the Drop Shadow box and displays the

Drop Shadow layer style options. The preview at right now includes the bevel and the
default drop shadow.
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5 The default Drop Shadow options are fine, so click Color Overlay in the Styles list.

6 In the Color Overlay area, click the color swatch to open the Color Picker, and then
choose a shade of yellow (we used R=255, G=218, and B=47). Click OK to close the
Color Picker and return to the Layer Style dialog box.
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7 Examine the Scrapbook text in the image window. Then click OK to accept the
settings and close the Layer Style dialog box.
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8 In the Layers palette, notice the list of effects nested in the Scrapbook type layer.

| Marmal v |

Locki [ 4 R

 Bevel and Emboss
® Color Ovetlay 2

You should see four rows of information. The top row identifies them as Effects. The
other three rows are the three styles that you applied to the layer: Drop Shadow, Bevel
and Emboss, and Color Overlay. A visibility eye icon (®) also appears next to each
effect. You can turn off any effect by clicking its eye icon to make it disappear. Clicking
this visibility box again restores both the icon and the effect. You can hide all three layer
styles by clicking the eye icon for Effects.

9 Before you continue, make sure that eye icons appear for all four items nested under
the Scrapbook layer.

10 To hide the layer styles listings, click the Reveal Layer Effects arrow to collapse the
effects list.
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Lock: [ o+ @ Locki (3 7+ @
T

B Effects
| ® Drop Shadow
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Updating the layer effect

Layer effects are automatically updated when you make changes to a layer. You can edit
the text and watch how the layer effect tracks the change.

1 In the Layers palette, turn on visibility for the 2 type layer and select it to make
it active.

2 In the toolbox, make sure that the Horizontal Type tool (T) is still selected, but do
not click in the image window yet.

3 In the tool options bar, set the font size to 225 points and press Enter or Return.

Although you didn’t select the text by dragging the Type tool (as you would have to do
in a word-processing program), the “2” now appears in 225-point type.

4 Using the Horizontal Type tool, select the “2” and change it to 3.

Notice that the text formatting and layer styles remain applied.

Ll cussf e matling iy e

A s of Ml st s
- Burown b

5 Select the Move tool (»+) and drag the “3” to center it vertically between the
“Scrapbook” text and the shell object.

Note: You don’t have to click the Commit Any Current Edits button after typing 3, because
choosing the Move tool has the same effect.

6 Choose File > Save.
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Adding depth with a drop shadow

The scrapbook cover is almost done; the elements are arranged correctly in the
composition. You'll finish up by adding a bit of depth to the Letter, Photo, and Shell
layers using simple drop shadow effects.

1 Select the Letter layer in the Layers palette, click the Add Layer Style button () at
the bottom of the palette, and choose Drop Shadow from the pop-up menu.

2 In the Drop Shadow pane of the Layer Styles dialog box, set the Opacity to 50%,
Distance to 5 pixels, Spread to 5%, and Size to 10 pixels. Then click OK to close the
dialog box and apply the effect.

Layer Style
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Blending Options: Default

Drop Shadow
[Tirmer Shadow
[Clouter Glow
[Cener Glow
[ Bevel and Embos:
[ Contour
[ Texture
[ satin

Drop Shadow
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| X
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| < g
|

E L s of e fora oy
¢ dast prines
e if

Quality

Contourt 1+ [Clant-sliased
[ color Guerlay gﬁ

[ Gradient Overlay Holeali ) [ J* |

[JPahern Overlay [Layer Knocks Out Drop Shadow |
[[stroke

Instead of creating another drop shadow for the photo and shell images from scratch,
we'll copy this one.
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3 Press Alt (Windows) or Option (Mac OS) and drag the Drop Shadow layer style
icon (®) from the Letter layer onto the Photo layer.
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4 Repeat Step 3 to add a drop shadow to the Shell layer.

5 Asalast step, to give just a bit more depth below the Shell layer, double-click its layer
style icon to open the Layer Styles dialog box. Select Drop Shadow from the Styles list
and change the Size to 25 pixels. Click OK to accept the change and close the dialog box.

Your final image and Layers palette should resemble the figure above.
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LESSON 5
Layer Basics

Flattening and saving files

When you finish editing all the layers in your image, you can merge or flatten layers

to reduce the file size. Flattening combines all the layers into a single background.
However, you shouldn’t flatten an image until you are certain that you're satisfied with
all your design decisions. Rather than flattening your original PSD files, it’s a good idea
to save a copy of the file with its layers intact, in case you need to edit a layer later.

To appreciate what flattening does, notice the two numbers for the file size in the status
bar at the bottom of the image window.

Note: Click the status bar pop-up menu arrow and choose Show > Document Sizes if the
sizes do not appear in the status bar.

[100%c [68] Doc: 918.5K/7.687M m
N

The first number represents what the file size would be if you flattened the image. The
second number represents the file size without flattening. This lesson file, if flattened,
would be about 918.5 KB, but the current file is actually much larger—about 8.78 MB.
So flattening is well worth it in this case.

1 If the Type tool (T) is currently selected in the toolbox, select any other tool, to
be sure that you're no longer in text-editing mode. Then choose File > Save (if it is

available) to be sure that all your changes have been saved in the file.

2 Choose Image > Duplicate.

3 In the Duplicate Image dialog box, name the file 05Flat.psd and click OK.
4 Leave the 05Flat.psd file open, but close the 05Working.psd file.
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5 Choose Flatten Image from the Layers palette menu.
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6 Choose File > Save. Even though you chose Save rather than Save As, the Save As
dialog box appears.

7 Make sure that the location is the Lessons/Lesson05 folder, and then click Save to
accept the default settings and save the flattened file.

You have saved two versions of the file: a one-layer, flattened copy as well as the original
file, in which all the layers remain intact.

Q If you want to flatten only some of the layers in a file, click the eye icons to hide
the layers you don’t want to flatten, and then choose Merge Visible from the Layers
palette menu.
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%EXTRA CREDIT Take the blinking and bad poses out of an otherwise great family
portrait with the Auto Align Layers feature. For an overview of this feature, watch the
Auto Align QuickTime movie on the Adobe Photoshop CS3 Classroom in a Book CD
in Movies/Auto Align.mov. Double-click the file to open it; then click the Play button.

1 Open FamilyPhoto.PSD in your Lesson05 folder.

2 In the Layers palette, turn Layer 2 on and off to see the two similar photos. When
both layers are visible, Layer 2 shows the tall man in the center blinking, and the
two girls in the lower left looking away. You'll align the two photos, and then use the
Eraser tool to brush out the parts of the photo on Layer 2 that you want to improve.

3 Make both layers visible, and Shift-click to select them. Choose Edit > Auto-Align
Layers; click OK to accept the default Auto position. Now click the eye icon next to
Layer 2 off and on to see that the layers are perfectly aligned.

Now for the fun part! You'll brush out the photo where you want to improve it.

4 Select the Eraser tool in the toolbox, and pick a soft, 45-point brush in the tool
options bar. Start brushing in the center of the blinking-man’s head to reveal the
smiling face below. Repeat this erasing on the two girls looking away, until they
look into the camera. You've created a natural family snapshot.
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Review

Review questions
1 What is the advantage of using layers?

2 When you create a new layer, where does it appear in the Layers palette stack?

3 How can you make artwork on one layer appear in front of artwork on
another layer?

4 How can you manipulate multiple layers simultaneously?

5 When you've completed your artwork, what can you do to minimize the file
size without changing the quality or dimensions?

Review answers

1 Layers let you move and edit different parts of an image as discrete objects. You
can also hide individual layers as you work on other layers by clicking to remove
the eye icons (9%) for the layers you don’t need to see.

2 The new layer always appears immediately above the active layer.

3 You can make artwork on one layer appear in front of artwork on another
layer by dragging layers up or down the stacking order in the Layers palette, or by
using the Layer > Arrange subcommands—Bring to Front, Bring Forward, Send
to Back, and Send Backward. However, you cannot change the layer position of a
Background layer.

4 You can link the layers by first selecting one of the layers in the Layers palette.
Then you click the box to the left of the Layer name of the layer to which you
want to link it. Once linked, both layers can be moved, rotated, and resized
together.

5 You can flatten the image, which merges all the layers onto a single
background. It's a good idea to duplicate image files with layers intact before you
flatten them, in case you have to make changes to a layer later.



